
May 14, 2025 • Brussels

Attack Flow Training:
3 – Using Attack Flow Builder

@2025 THE MITRE CORPORATION. ALL RIGHTS RESERVED. APPROVED FOR PUBLIC RELEASE. DISTRIBUTION UNLIMITED 25-00912-5.



2

▪ 1 – Introduction to Attack Flow

▪ 2 – Tagging Techniques in Narrative Reports

▪ 3 – Using Attack Flow Builder

▪ Lightning Talk

▪ 4 – Building An Attack Flow

▪ Lightning Talk

▪ 5 – Attack Flow 3 Preview

▪ Lightning Talk

▪ 6 – Visualization

Agenda
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Break

Break
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Overview of Attack Flow Builder
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Web App for Diagramming Attacks
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• Open source, web-based tool.

• Similar to Visio: create nodes (boxes) 

and connect with edges (lines).

• Create, edit, export, and present flows.

• Private: flow data stays in the browser. 

We do not collect or share it.

• Can be hosted at your organization for 

additional privacy & assurance.
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Web App for Diagramming Attacks
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Menu bar: new flow, open flow, 

export, copy/paste, etc.

Select: Menu bar → Edit→ 

Create → … to get started with 
adding items
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Web App for Diagramming Attacks
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Canvas: this is where you 

draw the diagram, the nodes, 

and the edges.
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Web App for Diagramming Attacks
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Properties: when you select an 

item in the diagram, its 

properties appear here and you 

may edit them
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Web App for Diagramming Attacks
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Validation: displays any 

problems with the flow. click on 

an issue to zoom to the 

affected item
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Web App for Diagramming Attacks
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Footer
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Attack Flow Building Blocks
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Building Blocks: Action
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• Actions are the backbone of Attack 

Flow. They describe what the 

adversary is doing at the TTP level 

(tactic, technique, procedure).

• A action should at least have a name 

and description. The name is 

displayed in the blue header, the 

description is displayed underneath.

• Each action may be mapped to 

ATT&CK but not required to do so. (It 

is called “Attack Flow”, not “ATT&CK 

Flow”.)
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Building Blocks: Action Properties
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Building Blocks: Action Confidence
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Term Description Confidence Value Confidence Range

Speculation Information that is purely speculative or hypothetical, 
e.g. the author imagines a what-if scenario.

0 0-0

Very Doubtful Information that is very unlikely to be true. All of the 
available evidence is against it, or it may have bias in 

its reporting, e.g. an adversary providing attribution 
information.

10 1-20

Doubtful Information that is unlikely to be true. Most of the 
available evidence is against it.

30 21-40

Even Odds Information that is equally like to be true as not true; a 
coin flip. The available evidence is equally weighted in 

support and against.

50 41-60

Probable Information that is likely to be true. Most of the 
available evidence supports it.

70 61-80

Very Probable Information that is very likely to be true. All of the 
available evidence supports it.

90 81-99

Certainty Information that is unquestionably true. 100 100-100
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Building Blocks: Action Connections
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When an action is connected to 

another action, it represents an 

effectual relationship. 

The first action produces an effect 
that positions the adversary to take 

the next step.

Reminder: the 

arrows are not 

chronological!
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Building Blocks: Condition

@2025 THE MITRE CORPORATION. ALL RIGHTS RESERVED. APPROVED FOR PUBLIC RELEASE. DISTRIBUTION UNLIMITED 25-00912-5.

• Conditions are used to model decision points 

in the attack flow, show how the adversary 

responds to failed attempts, or to represent 

the state of an asset.

• The description is a human-readable text that 

is displayed in the green header.

• Can optionally use the STIX Pattern 

language for machine-readable condition 

evaluation.

• Unlike other nodes, conditions have two 

types of ports (true, false).
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Building Blocks: 
Condition

• NotPetya checks if Kaspersky is running on 

the system.

• If yes: corrupts the Master Boot Record.

• If no: installs a malicious bootloader.
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Building Blocks: 
Condition

• Helpful for easing understanding of complex 

topics.

• E.g. in NotPetya, the privilege elevation is 

complex and requires knowledge of 

Windows internals. 

• The condition object makes the flow 

easier to read.
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Building Blocks: Operator
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• Operators allow multiple 

attack paths to converge.

• The OR operator requires 

any of its inputs to succeed 

before execution continues.

• The AND operator requires 

all its inputs to succeed 

before execution continues.
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Building Blocks: OR 
Operator

▪ NotPetya has two privilege escalation 

techniques.

▪ If either one succeeds, then it it can execute 

its lateral movement technique.
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Building Blocks: AND Operator
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• In the Tesla flow, the 

adversary must position 

infrastructure, configure a 

non-standard port, and 

deploy a Kubernetes 

container.

• If they succeed in all three, 

then they can execute 

resource hijacking.
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Building Blocks: Operator Anti-pattern
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• An operator with a single 

input doesn’t do anything.

• This is not recommended.

• We see this in some flows 

due to a misunderstanding 

about how to use operators.
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Building Blocks: Assets
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• Assets represent information 

systems, data, or users involved in 

an attack.

• Very generalized: it contains only a 

name and a description.

• You can add additional structured 

data using STIX.
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Building Blocks: Asset Connections
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• An edge from an action to an asset 

indicates that the action modifies 

the state of that asset.

• An edge from an asset to an action 

indicates that the action depends 

on the state of that asset.
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Building Blocks: Asset 
Anti-pattern

▪ Inserting an asset in between actions is 

allowed but not recommended.

▪ Actions should connect to other or operators 

in a continuous chain. No other nodes 

should come between actions.
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Building Blocks: Asset Structured Data
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• While assets are very simple on 

their own (just name and 

description) they can be enriched 

using STIX objects.

• For example, add “User Account” 

nodes to an asset; this creates 

structured data about the impacted 

accounts.
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Attack Flow STIX Nodes
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STIX Nodes

▪ Attack flow supports all STIX 2.0 

types:

▪ 18 STIX Domain Object (SDO) Types

▪ 18 STIX Cyber Observable (SCO) Types

▪ These types are defined in the STIX 

specification; we adhere to that.

▪ STIX nodes can be connected with 

edges just like any other node.

▪ You can export an Attack Flow to 

a STIX bundle and import it into any 

tool that can process STIX 

(e.g., OpenCTI, etc.)
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STIX Nodes

This example (that we saw a 

few slides ago) shows the 

“User Account” STIX enriching 

an Asset node.

In STIX this is represented by 

the "user-account--" 

observable type.
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STIX Nodes

This example shows the 

”Vulnerability” STIX type used 

to enrich an Action node. 
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STIX Nodes

▪ All of the properties defined in STIX are 

settable and viewable in Attack Flow Builder.

▪ For example, “File” is a STIX Observable 

with 9 property fields. Below is the JSON 

representation of a File Object (how the data 

will look exported from Flow)
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STIX Data Validation

STIX is easy to work with in Attack Flow. The 

validator helps you enter STIX data correctly.
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Attack Flow Features
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Splash Screen
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If you accidentally close a flow without 

saving, you can recover it here.

Create or open a flow
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Moving Around

▪ Click anywhere on the 

background and drag to 

pan the diagram.

▪ Use the scroll wheel to 

zoom in and out. (Or use 

the “View” menu.)
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Creating a Node

▪ Right click on the diagram and 

select Create → Attack Flow 

→ Action.

▪ Or go to the menu bar → 

Edit → Create → ...

▪ Click the action to display its 

properties in the side panel.

▪ Key in the properties. 

▪ Some properties 

autocomplete, e.g. tactic and 

technique.
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Connecting Nodes

▪ When the mouse hovers over 

a node, it displays its anchor 

points.

▪ Click on an anchor and drag to 

create a new line.

▪ Connect the other end of the 

line to a different anchor.

▪ Once connected, lines follow 

the nodes they are attached to 

if the node is moved.
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Exporting
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Save a flow (or part of a flow) as a PNG 

image. Huge timesaver for 

presentations. (Including the one you’re 

viewing right now.)

Export to STIX bundle
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Zooming Shortcuts
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Press Shift+Z to zoom 

into a selected object.

Press Shift+C to zoom to 

the next set of 

connected nodes.

(Also accessible from 

the “View” menu)
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Edit
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Undo or redo the last action.

Search the flow

Cut and paste any nodes or edges
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Search a Flow

▪ Keyword search to quickly 

find specific items in the 

flow.

▪ It zooms into the matching 

items so that you can see 

them clearly.
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Layout
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The layout menu lets you change how 

items are stacked in the diagram. (In 

practice, you don’t need to do this very 

often.)
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End of Section 3
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▪ 1 – Introduction to Attack Flow

▪ 2 – Tagging Techniques in Narrative Reports

▪ 3 – Using Attack Flow Builder

▪ Lightning Talk

▪ 4 – Building An Attack Flow

▪ Lightning Talk

▪ 5 – Attack Flow 3 Preview

▪ Lightning Talk

▪ 6 – Visualization

Agenda
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